[44] | 1 | #! /usr/bin/make -f |
---|
| 2 | |
---|
| 3 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 4 | include /usr/share/cdbs/1/rules/simple-patchsys.mk |
---|
| 5 | include /usr/share/cdbs/1/class/autotools.mk |
---|
| 6 | |
---|
| 7 | # Uncomment this to turn on verbose mode. |
---|
| 8 | export DH_VERBOSE=1 |
---|
| 9 | |
---|
| 10 | DEB_CONFIGURE_EXTRA_FLAGS := \ |
---|
| 11 | --enable-sharedlibs=gcc \ |
---|
| 12 | --prefix=/usr \ |
---|
| 13 | --with-python=python \ |
---|
| 14 | --sysconfdir=\$$\{prefix\}/etc/mpich2 \ |
---|
| 15 | --includedir=\$$\{prefix\}/usr/include/mpich2 |
---|
| 16 | |
---|
| 17 | DEB_MAKE_INSTALL_TARGET := install prefix=$(CURDIR)/debian/tmp/usr exec_prefix=$(CURDIR)/debian/tmp/usr includedir=$(CURDIR)/debian/tmp/usr/include/mpich2 libdir=$(CURDIR)/debian/tmp/usr/lib sysconfdir=$(CURDIR)/debian/tmp/etc/mpich2 mandir=$(CURDIR)/debian/tmp/usr/share/man docdir=$(CURDIR)/debian/tmp/usr/share/doc/mpich2 |
---|
| 18 | |
---|
| 19 | #DEB_MAKE_CLEAN_TARGET += |
---|
| 20 | |
---|
| 21 | DEB_INSTALL_CHANGELOGS_ALL := CHANGES |
---|
| 22 | |
---|
| 23 | clean:: |
---|
| 24 | rm -rf bin/ lib/ src/mpe2/bin src/mpe2/lib src/binding/f77/conftest.f90 src/binding/f77/include |
---|
| 25 | |
---|
| 26 | rm -rf src/mpe2/include/mpe_graphics.h src/mpe2/include/mpe_graphicsf.h src/mpe2/include/mpe_log.h \ |
---|
| 27 | src/mpe2/include/mpe_logf.h src/mpe2/include/mpe_misc.h src/mpi/romio/adio/include/romioconf.h |
---|
| 28 | |
---|
| 29 | rm -rf src/mpe2/sbin/mpeinstallcheck src/mpe2/src/slog2sdk/config.log src/mpid/ch3/channels/sock/config.log \ |
---|
| 30 | src/mpid/ch3/channels/sock/config.status src/mpid/ch3/channels/sock/config.system maint/config.cache \ |
---|
| 31 | maint/config.status maint/config.log src/mpe2/src/slog2sdk/trace_rlog/config.log src/mpe2/src/slog2sdk/trace_sample/config.log |
---|
| 32 | |
---|
| 33 | rm -rf src/mpe2/src/slog2sdk/simple.class src/mpe2/src/slog2sdk/simple.jar src/mpe2/src/slog2sdk/simple_swing.class |
---|
| 34 | |
---|
| 35 | rm -rf src/mpi/romio/localdefs src/mpid/ch3/.deps src/mpid/ch3/channels/sock/localdefs .mpich2 |
---|
| 36 | |
---|
| 37 | rm -rf src/util/thread/localdefs src/pm/mpd/*.pyc src/pm/mpd/*.3 |
---|
| 38 | |
---|
| 39 | rm -rf src/mpid/ch3/channels/sock/Makefile src/mpid/ch3/channels/sock/src/Makefile src/mpid/common/locks/Makefile \ |
---|
| 40 | src/nameserv/mpd/Makefile src/nameserv/test/Makefile examples/mpiexec/Makefile src/mpi/debugger/Makefile \ |
---|
| 41 | src/mpi/romio/mpi-io/glue/mpich1/Makefile src/mpi/romio/mpi-io/glue/mpich2/Makefile src/binding/f90/Makefile \ |
---|
| 42 | src/mpi/romio/mpi-io/glue/default/Makefile |
---|
| 43 | |
---|
| 44 | rm -f maint/config.cache maint/config.status maint/config.log src/mpe2/src/slog2sdk/trace_rlog/config.log \ |
---|
| 45 | src/mpe2/src/slog2sdk/trace_sample/config.log |
---|
| 46 | |
---|
| 47 | rm -f src/mpe2/src/slog2sdk/trace_rlog/libtool src/mpe2/src/slog2sdk/trace_sample/libtool |
---|
| 48 | |
---|
| 49 | binary-install/mpich2:: |
---|
| 50 | mv debian/mpich2/usr/bin/mpicc debian/mpich2/usr/bin/mpicc.mpich2 |
---|
| 51 | mv debian/mpich2/usr/share/man/man1/mpicc.1 debian/mpich2/usr/share/man/man1/mpicc.mpich2.1 |
---|
| 52 | mv debian/mpich2/usr/bin/mpicxx debian/mpich2/usr/bin/mpicxx.mpich2 |
---|
| 53 | mv debian/mpich2/usr/share/man/man1/mpicxx.1 debian/mpich2/usr/share/man/man1/mpicxx.mpich2.1 |
---|
| 54 | mv debian/mpich2/usr/bin/mpif77 debian/mpich2/usr/bin/mpif77.mpich2 |
---|
| 55 | mv debian/mpich2/usr/share/man/man1/mpif77.1 debian/mpich2/usr/share/man/man1/mpif77.mpich2.1 |
---|
| 56 | |
---|
| 57 | binary-install/mpich2-mpd:: |
---|
| 58 | mv debian/mpich2-mpd/usr/share/man/man1/mpiexec.1 debian/mpich2-mpd/usr/share/man/man1/mpiexec.mpich2.1 |
---|
| 59 | |
---|